Monday, March 2, 2009

Default Point Label Style in AutoCAD Civil 3D 2009

Today I'd like to share a little about what I learned last week about default point label styles, template drawing, and the _All Points point group in AutoCAD Civil 3D 2009.

[Note: There is more about controlling the default points insertion style here by John Evans.]

Our issue at Hubbard Engineering was that any points we imported or created were coming in with no label and only an "x" initially showing. We needed to change the default point style and point label style for points creation.

We tried unsuccessfully changing the Default Styles under General, Toolspace, Settings tab, \Point\Commands\CreatePoints, [right-click]Edit Command Settings..., Default Styles. In fact, I still can't see any effect those have. So I did a little more research, and found that my issue was in Point Groups.

From what I discovered and can tell, AutoCAD Civil 3D always creates new points in the _All Points group, which is a system group. I can't tell a way to change this. I wanted newly created points to be visible, so I needed to go to General, Toolspace, Prospector tab,

5 comments:

Mary said...

Hi Tom,

Don't you LOVE Civil 3D 2009?

On a different subject,
Have you thought about combining your CNM with VB?

Mary

Thomas Gail Haws said...

Yes, I do love Civil 3D 2009. CNM does use a bit of VB. What did you have in mind?

Wesley Ashworth said...

I had the same problem until I setup a descriptor file, similar to the old Land Desktop. Go to Settings in Prospector, under point right click on Description Key Sets and pick New. Then set up the descriptor codes as you wish along with point, label styles and layer.

Wesley Ashworth

homa zarini said...

the color of my "all points group" and another point group is the same, and i want them to be diffrent but i cant. please help me

Thomas Gail Haws said...

HZ, I can help you by phone. http://www.hawsedc.com/contact.php

Facebook Share